УкраїнськаEnglishРocсийский
Вход/Новый
В теме нет новых постов

Сборка Open Scada в Open Suse Linux


Автор Сообщение
Сообщение создано: 16. 03. 2014 [18:48]
pentagon128
Руслан Кучерявый
Создатель темы
Зарегистрирован(а) с: 15.11.2011
Сообщения: 102
Добрый день! Пытаюсь собрать Open Scada v2073 из исходников (SVN ветка trunk) в Open Suse v13.1 x64 с установленными обновлениями на 17.03.2014. Использую утилиты из набора Autotools и WIKI руководство по сборке Open Scada из исходников. На этапе глобальной сборки команда "$ ./configure" выдаёт ошибку при проверке библиотеки базы данных Firebird, что библиотека версии >=2.0.0 не найдена. Разрешить зависимости не получается. Библиотеки Firebird v2.5xxx установлены. Из репозиториев SUSE установлены и библиотеки и сервер Firebird. См. прилагаемые копии экранов (подключенные репозитории, установленные из них пакеты Firebird, сообщение о ошибке). В исходном коде Open Scada (файлы в папке \src\moduls\bd\FireBird\)явной ссылки на используемую библиотеку firebird не нахожу. Складывается впечатление что где-то в исходном коде Open Scada есть ссылка в include файлах на древнюю версию библиотеки Firebird. Кстати, при установке Open Scada где-то год полтора назад (несколько версий назад) установщик требовал наличия древних Firebird библиотек которые приходилось выискивать в репозитариях, иначе установка не проходила. Сейчас установка Open Scada v0_8_0_9 на Open Suse проходит гладко. Конечно можно как временное решение в параметрах "$ ./configure" исключить модуль БД FireBird, но есть желание скомпилировать полную сборку под x64.

[Сообщение редактировалось 2 раз(а), в последний раз 16.03.2014 в 18:55.]
Вложенный файл

2014-03-16_230801.png (Тип файла: image/png, Размер: 571.11 килобайт) — 1787 загрузок
2014-03-17_001725.png (Тип файла: image/png, Размер: 715.1 килобайт) — 1764 загрузок
2014-03-17_001746.png (Тип файла: image/png, Размер: 679.46 килобайт) — 1618 загрузок
Сообщение создано: 16. 03. 2014 [20:39]
roman
Roman Savochenko
Moderator
Contributor
Developer
Зарегистрирован(а) с: 12.12.2007
Сообщения: 3679
"pentagon128" wrote:

Из репозиториев SUSE установлены и библиотеки и сервер Firebird.

Это проблема кривизны и разброда в конфигурации Firebird, с чем я даже бороться перестал и отдал эту проблему на тех кому FireBird в типа SuSE нужен.
У меня на ALTLinux он нормально конфигурируется.

"pentagon128" wrote:

Складывается впечатление что где-то в исходном коде Open Scada есть ссылка в include файлах на древнюю версию библиотеки Firebird.

На какую это древнюю? OpenSCADA реализует поддержку только для версий FireBird >= 2.
И вообще используется только #include <ibase.h>
А путь к нему это дело кривой конфигурации и обнаружения его позиции в конкретной системе, как и для библиотеки.

Learn, learn and learn better than work, work and work.
Сообщение создано: 17. 03. 2014 [08:08]
pentagon128
Руслан Кучерявый
Создатель темы
Зарегистрирован(а) с: 15.11.2011
Сообщения: 102
Спасибо за подсказку, теперь понимаю что Open Scada не при чём. Похоже в моём случае модуль Firebird лучше исключить из сборки, тем более что я предпочитаю связку MySQL и SQLite. MySQL на SUSE поднимается безпроблемно, достаточно хорошо документирован. Вчера пробегался по форумам пользователей Firebird, имеются косяки (замена разработчиками имён внутренних утилит Firebird в новых версиях) из-за чего постоянно возникают внутренние конфликты, и старое ПО работающее с Firebird отказывается работать с новым, лечится форумчанами Firebird ручной правкой сразу нескольких конфигов Firebird. Установить последнюю версию FirebirdCS-2.5.2.26540-0.amd64.rpm с сайта разработчика под SUSE не получается, выдаёт внутреннюю ошибку.
Сообщение создано: 17. 03. 2014 [20:34]
pentagon128
Руслан Кучерявый
Создатель темы
Зарегистрирован(а) с: 15.11.2011
Сообщения: 102
После разрешения зависимостей пакетов глобальная сборка на этапах "make" и "make install" прошла успешно (без модуля FireBird). Далее "затык" т.к. файла "openscada_demo" что в исходниках, что в установленной системе не обнаруживается. Если произвести запуск /usr/bin/openscada то происходит запуск с запросом пароля.
Сообщение создано: 17. 03. 2014 [21:05]
roman
Roman Savochenko
Moderator
Contributor
Developer
Зарегистрирован(а) с: 12.12.2007
Сообщения: 3679
"pentagon128" wrote:

Если произвести запуск /usr/bin/openscada то происходит запуск с запросом пароля.

А openscada_start, openscada_AGLKS?

Хотя openscada_AGLKS там тоже нет.
Сейчас устанавливается только openscada_start, как основной пускающий скрипт GUI приложения, с меню выбора проектов.
В RPM *.spec и DEB/ ещё на него устанавливаются ссылки предустановленных проектов типа: openscada_AGLKS, openscada_Boiler.

Learn, learn and learn better than work, work and work.
Сообщение создано: 18. 03. 2014 [09:48]
pentagon128
Руслан Кучерявый
Создатель темы
Зарегистрирован(а) с: 15.11.2011
Сообщения: 102
Спасибо Роман! :DСтартовый скрипт "openscada_start" работает. Я этот скрипт и раньше пробовал запускать, но запускал в файловом менеджере krusader без отображения в терминале. Поэтому скрипт останавливался на выборе пользователя (но я этого не видел), приходилось его снимать через диспетчер задач. Теперь когда запустил его в окне терминала прямой командой - всё стало понятно. Через меню создал тестовый проект, запустил AGLKS. Далее буду пробовать собрать RPM :D P.S. Обратил внимание что сайт форума смайлики не отображает, невижу их в Opera и в Chrome, при создании сообщения - смайлик вставляется кодом.

[Сообщение редактировалось 1 раз(а), в последний раз 18.03.2014 в 09:53.]
Сообщение создано: 18. 03. 2014 [20:32]
pentagon128
Руслан Кучерявый
Создатель темы
Зарегистрирован(а) с: 15.11.2011
Сообщения: 102
Успешно собрал RPMы из готовых исходников "openscada-0.8.0.9.tar.lzma" и "openscada-res-0.8.0.9.tar.lzma" с компиляцией сначала и исключением Firebird. Как я понимаю если заменить начинку lzma архивов соответствующим содержимым папки trunk из SVN то будут созданы RPMы промежуточной свежей версии, но необходимости это делать пока нет. Заодно в "openscada.spec" файле вычитал пароль по умолчанию для root.

[Сообщение редактировалось 1 раз(а), в последний раз 18.03.2014 в 20:35.]
Сообщение создано: 18. 03. 2014 [20:49]
roman
Roman Savochenko
Moderator
Contributor
Developer
Зарегистрирован(а) с: 12.12.2007
Сообщения: 3679
"pentagon128" wrote:

Поэтому скрипт останавливался на выборе пользователя (но я этого не видел), приходилось его снимать через диспетчер задач.

Скрипт запуска не даёт выбора пользователей.
А вообще меню выбора проекта может строиться с помощью:
- dialog (консоль)
- kdialog
- zenity
- Xdialog

Т.е. если меню нет то нужно установить что либо из перечисленного, хотя в сборке KDE4 на SuSE замечался бок, когда он создаёт и определяет терминал, хотя не рисует его. Из-за чего для запуска из меню Десктопа пришлось терминал гасить прямо.

"pentagon128" wrote:

Обратил внимание что сайт форума смайлики не отображает, невижу их в Opera и в Chrome, при создании сообщения - смайлик вставляется кодом.

Смайлики я специально отключил в виду кривизны их подстановки в mm_forum, когда смайлики сквозняком расставляются и по блокам вставок исходного текста.

Learn, learn and learn better than work, work and work.
Сообщение создано: 18. 03. 2014 [21:08]
pentagon128
Руслан Кучерявый
Создатель темы
Зарегистрирован(а) с: 15.11.2011
Сообщения: 102
"Скрипт запуска не даёт выбора пользователей."

Я имел в виду "ожидание выбора оператором" из списка "новый проект", "demo ALGKS" и т.п.
По остальным вопросам - всё ясно.



10828